We’re working to upgrade our current ASP.Net 1.1 project to an ASP.Net 2.0 Web Application project (so that’s not the new Visual Studio 2005 website model). We had some basic minor migration issues, which have all been addressed and are currently solved. The only problem we have right now is with the UIP Application Block. There are several people online stating they’ve got UIPAB working in a .Net 2.0 project. Unfortunately, we haven’t got it working… yet ;)

The fact they’ve got it working might be in several things: are we using the UIPAB differently? Is the problem in the fact that we’re using the Web Application Project projecttype? And maybe others have got it working in WinForms apps, but not in WebApps? Anyway, we changed the UIPConfigSchema based on this thread to get it to ‘run’ without generating runtime errors. At this point, everything compiles and runs without runtime errors… What’s the problem, you ask? The UIPAB is supposed to redirect to the first page of the view as soon as a button is pressed, but doesn’t. Actually, it doesn’t do anything. After calling UIPManager.StartOpenNavigationTask, the code execution eventually stops in the WebformViewManager class at the RedirectToNextView method with a ThreadAbortException. This seems to be caused by the Response.Redirect, which natively causes this exception. When you use the override with the EndResponse boolean set to false, this should avoid the Response.End being called and so should stop exception from being thrown. The UIPAB uses this overload, but the exception is still thrown. I’m not sure if that is the problem, but it seems so at this point.

We’re looking in to this right now. If we find anything, I’ll keep you posted. On the other hand: if you have any pointers, I’m open to suggestions. Drop me a line.